Flowdock
method

can_use_fast_cache_version?

Importance_1
v6.0.0 - Show latest stable - 0 notes - Class: Integration
  • 1.0.0
  • 1.1.6
  • 1.2.6
  • 2.0.3
  • 2.1.0
  • 2.2.1
  • 2.3.2
  • 2.3.8
  • 3.0.0
  • 3.0.9
  • 3.1.0
  • 3.2.1
  • 3.2.8
  • 3.2.13
  • 4.0.2
  • 4.1.8
  • 4.2.1
  • 4.2.7
  • 4.2.9
  • 5.0.0.1
  • 5.1.7
  • 5.2.3
  • 6.0.0 (0)
  • 6.1.3.1 (0)
  • What's this?
can_use_fast_cache_version?(timestamp) private

Detects if the value before type cast can be used to generate a cache_version.

The fast cache version only works with a string value directly from the database.

We also must check if the timestamp format has been changed or if the timezone is not set to UTC then we cannot apply our transformations correctly.

Show source
Register or log in to add new notes.