Flowdock
method

requirements

Importance_0
v3.0.9 - Show latest stable - 0 notes - Class: ActionDispatch::Routing::DeprecatedMapper::Resource
  • 1.0.0
  • 1.1.6
  • 1.2.6
  • 2.0.3
  • 2.1.0
  • 2.2.1
  • 2.3.2
  • 2.3.8
  • 3.0.0 (0)
  • 3.0.9 (0)
  • 3.1.0
  • 3.2.1
  • 3.2.8
  • 3.2.13
  • 4.0.2
  • 4.1.8
  • 4.2.1
  • 4.2.7
  • 4.2.9
  • 5.0.0.1
  • 5.1.7
  • 5.2.3
  • 6.0.0
  • 6.1.3.1
  • What's this?
requirements(with_id = false) public

No documentation

This method has no description. You can help the Ruby on Rails community by adding new notes.

Hide source
# File actionpack/lib/action_dispatch/routing/deprecated_mapper.rb, line 237
        def requirements(with_id = false)
          @requirements   ||= @options[:requirements] || {}
          @id_requirement ||= { :id => @requirements.delete(:id) || /[^#{Routing::SEPARATORS.join}]+/ }

          with_id ? @requirements.merge(@id_requirement) : @requirements
        end
Register or log in to add new notes.