Flowdock
method

install

Importance_1
Ruby latest stable (v1_9_3_392) - 0 notes - Class: DependencyInstaller
install(dep_or_name, version = Gem::Requirement.default) public

Installs the gem dep_or_name and all its dependencies. Returns an Array of installed gem specifications.

If the :prerelease option is set and there is a prerelease for dep_or_name the prerelease version will be installed.

Unless explicitly specified as a prerelease dependency, prerelease gems that dep_or_name depend on will not be installed.

If c-1.a depends on b-1 and a-1.a and there is a gem b-1.a available then c-1.a, b-1 and a-1.a will be installed. b-1.a will need to be installed separately.

Show source
Register or log in to add new notes.