Flowdock
method

parse!

Importance_0
Ruby on Rails latest stable (v4.0.2) - 0 notes - Class: Install

Method deprecated or moved

This method is deprecated or moved on the latest stable version. The last existing version (v3.2.13) is shown here.

These similar methods exist in v4.0.2:

parse!(args) public

No documentation

This method has no description. You can help the Ruby on Rails community by adding new notes.

Hide source
# File railties/lib/rails/commands/plugin.rb, line 407
      def parse!(args)
        options.parse!(args)
        if args.blank?
          puts options
          exit 1
        end
        environment = @base_command.environment
        install_method = determine_install_method
        puts "Plugins will be installed using #{install_method}" if $verbose
        args.each do |name|
          ::Plugin.find(name).install(install_method, @options)
        end
      rescue StandardError => e
        puts "Plugin not found: #{args.inspect}"
        puts e.inspect if $verbose
        exit 1
      end
Register or log in to add new notes.