Flowdock
method

description

Importance_0
v1_9_3_392 - Show latest stable - 0 notes - Class: InstallCommand
description() public

No documentation

This method has no description. You can help the Ruby community by adding new notes.

Hide source
# File lib/rubygems/commands/install_command.rb, line 46
  def description # :nodoc:
    The install command installs local or remote gem into a gem repository.For gems with executables ruby installs a wrapper file into the executabledirectory by default.  This can be overridden with the --no-wrappers option.The wrapper allows you to choose among alternate gem versions using _version_.For example `rake _0.7.3_ --version` will run rake version 0.7.3 if a newerversion is also installed.If an extension fails to compile during gem installation the gemspecification is not written out, but the gem remains unpacked in therepository.  You may need to specify the path to the library's headers andlibraries to continue.  You can do this by adding a -- between RubyGems'options and the extension's build options:  $ gem install some_extension_gem  [build fails]  Gem files will remain installed in \\  /path/to/gems/some_extension_gem-1.0 for inspection.  Results logged to /path/to/gems/some_extension_gem-1.0/gem_make.out  $ gem install some_extension_gem -- --with-extension-lib=/path/to/lib  [build succeeds]  $ gem list some_extension_gem  *** LOCAL GEMS ***  some_extension_gem (1.0)  $If you correct the compilation errors by editing the gem files you will needto write the specification by hand.  For example:  $ gem install some_extension_gem  [build fails]  Gem files will remain installed in \\  /path/to/gems/some_extension_gem-1.0 for inspection.  Results logged to /path/to/gems/some_extension_gem-1.0/gem_make.out  $ [cd /path/to/gems/some_extension_gem-1.0]  $ [edit files or what-have-you and run make]  $ gem spec ../../cache/some_extension_gem-1.0.gem --ruby > \\             ../../specifications/some_extension_gem-1.0.gemspec  $ gem list some_extension_gem  *** LOCAL GEMS ***  some_extension_gem (1.0)  $
  end
Register or log in to add new notes.