Flowdock
method

ensure_required_rubygems_version_met

Importance_0
Ruby latest stable (v1_9_3_392) - 0 notes - Class: Installer
ensure_required_rubygems_version_met() public

No documentation

This method has no description. You can help the Ruby community by adding new notes.

Hide source
# File lib/rubygems/installer.rb, line 393
  def ensure_required_rubygems_version_met
    if rrgv = spec.required_rubygems_version then
      unless rrgv.satisfied_by? Gem::Version.new(Gem::VERSION) then
        raise Gem::InstallError,
          "#{spec.name} requires RubyGems version #{rrgv}. " +
          "Try 'gem update --system' to update RubyGems itself."
      end
    end
  end
Register or log in to add new notes.