Flowdock
method

check_ruby_version

Importance_0
Ruby latest stable (v1_9_3_392) - 0 notes - Class: SetupCommand
check_ruby_version() public

No documentation

This method has no description. You can help the Ruby community by adding new notes.

Hide source
# File lib/rubygems/commands/setup_command.rb, line 51
  def check_ruby_version
    required_version = Gem::Requirement.new '>= 1.8.7'

    unless required_version.satisfied_by? Gem.ruby_version then
      alert_error "Expected Ruby version #{required_version}, is #{Gem.ruby_version}"
      terminate_interaction 1
    end
  end
Register or log in to add new notes.