Flowdock
method

assets_gemfile_entry

Importance_0
Ruby on Rails latest stable (v4.1.8) - 0 notes - Class: AppBase
assets_gemfile_entry() protected

No documentation

This method has no description. You can help the Ruby on Rails community by adding new notes.

Hide source
# File railties/lib/rails/generators/app_base.rb, line 241
      def assets_gemfile_entry
        return [] if options[:skip_sprockets]

        gems = []
        if options.dev? || options.edge?
          gems << GemfileEntry.github('sprockets-rails', 'rails/sprockets-rails', '2-1-stable',
                                    'Use latest 2.1 version of sprockets-rails')
          gems << GemfileEntry.github('sass-rails', 'rails/sass-rails', nil,
                                    'Use SCSS for stylesheets')
        else
          gems << GemfileEntry.version('sass-rails',
                                     '~> 4.0.3',
                                     'Use SCSS for stylesheets')
        end

        gems << GemfileEntry.version('uglifier',
                                   '>= 1.3.0',
                                   'Use Uglifier as compressor for JavaScript assets')

        gems
      end
Register or log in to add new notes.