Flowdock
class
Importance_2
Ruby on Rails latest stable (v4.0.2) - 1 note - Superclass: Rack::Auth::AbstractHandler
  • 1.0.0
  • 1.1.1
  • 1.1.6
  • 1.2.0
  • 1.2.6
  • 2.0.0
  • 2.0.3
  • 2.1.0
  • 2.2.1
  • 2.3.2 (0)
  • 2.3.8
  • 3.0.0
  • 3.0.5
  • 3.0.9
  • 3.1.0
  • 3.2.1
  • 3.2.3
  • 3.2.8
  • 3.2.13
  • 4.0.2
  • What's this?

Class deprecated or moved

This class is deprecated or moved on the latest stable version. The last existing version (v2.3.2) is shown here.

A class developed out of the request to use OpenID as an authentication middleware. The request will be sent to the OpenID instance unless the block evaluates to true. For example in rackup, you can use it as such:

  use Rack::Session::Pool
  use Rack::Auth::OpenIDAuth, realm, openid_options do |env|
    env['rack.session'][:authkey] == a_string
  end
  run RackApp

Or simply:

  app = Rack::Auth::OpenIDAuth.new app, realm, openid_options, &auth
Show files where this class is defined (1 file)
Register or log in to add new notes.
May 6, 2011
0 thanks

Using OpenID

–rails g nifty:authentication –redo rake db:migrate –add: before_filter :login_required, :except => :index to appropriate controllers.